Avada opdatering 4.x til 5

Når du skal til at opdatere til Avada 5 vil du se et skærmbillede der forklarer processen for dig og du bliver bedt om at bekræfte at du vil opgradere til Avada 5. Inden du går videre med dette er det vigtigt at du sørger for 2 ting.

Punkt 1: Har du en backup af dine filer og database?

  • Her er det ikke nok at du ved at din webhost eller udvikler har en. Du skal være 100% sikker på at den er tilgængelig og virker, for hvis opdateringen går galt, kan du ikke bare lige trykke fortryd for at få det tilbage igen. Derfor vil det være en god ide lige at lave en backup selv inden du fortsætter.

Punkt 2: Har du en udvikler til at hjælpe hvis det er nødvendigt?

  • Hvis det alligevel går galt, så er det en god ide at have en udvikler klar til at hjælpe. Det koster ofte ikke meget at have en udvikler på standby hvis der er behov for det. Opdateringen tager ikke mange minutter og du kan derfor slippe med et lille beløb for udvikleren skal vente. Du kan selvfølgelig også bare få udvikleren til at opdatere for dig.

Når du har din backup og din udvikler klar skal du sikre dig at alle dine plugins er opdateret til de nyeste versioner og derefter sørge for at du har den nyeste WordPress version.

Du kan nu fortsætte med opdateringen. Opdater din Avada ved at uploade de nye filer til din server og derefter skal du besøge din side og logge ind som admin (wp-admin).

Du vil i toppen få en besked om at du skal opdatere din fusion core, når du har gjort dette vil du kunne installere den nye fusion builder fra samme sted.

Når den nye Fusion Builder er installeret vil du skulle konvertere dine sider, da du ellers ikke vil have en fungerende side længere og ved redigering af en side vil du blive mødt med en besked om content error.

Når du får denne besked skal du have dit indhold konverteret til den nye version af Avada. Det gør du ved gå til menu punktet “Avada” -> “System status” og vælge Avada 5.0 migration som vist på billedet.

Kan du ikke finde punktet kan det være du skal registrere din Avada installation. Dette gør du i menu punktet Avada -> Product Registration og følger anvisningerne.

Når du starter konverteringen vil du først se en skærm som fortæller hvad der skal ske og at du ikke må lukke vinduet når du først har trykket start conversion.

Efterfølgende kan du se hvor langt du er i processen.

Indtil du er færdig

I langt de fleste tilfælde vil din side nu virke med en opdateret Avada.

Problemer ved opdatering

Specielt brugere af sprog plugin vil kunne opleve problemer med opdateringen, det samme ved opdatering af Avada 3 til Avada 4, hvis man ikke sikrede sig at alle plugins og WordPress er blevet opdateret før man opdaterede Avada.

Du kan stå med et problem hvor den bare bliver ved med at forsøge at opdatere samme sprog igen og igen. Dette kan ofte løses ved at deaktivere temaer via FTP eller andet file editor.

Du skal blot omdøbe mappen /wp-content/themes/ til noget andet og du er derefter ude at det opdaterings loop.

Får du en PHP fejl besked Warning / Fatal error og kan ikke aktiverer det nye plugin? Så er den mest sandsynlige årsag at du ikke har opdateret WordPress og alle plugins ELLER at din PHP version ikke er korrekt. Jeg har oplevet steder hvor de kørte med PHP 5.2 og der virker den ikke (7 er det det nye lige nu). Opdater til PHP 7 eller bed din webhost om at gøre det for dig. Du bør få vejledning omkring hvad du skal passe på med i forbindelse med et skift til PHP 7, men jeg anbefaler at du også kommer med på denne version.

Har du problemer med at shortcodes ikke længere virker. Så skyldes det muligvis at i den nye version af Avada at shortcode navne ikke det samme som tidligere. Eksempel [imageframe] hedder nu . Det er blot fusion_ foran alle shortcode der ikke virker, men kan tage tid hvis man har lavet mange sider med shortcode eller template filer med dem i.

Hvis det hele går galt, kan det anbefales at fjerne alle plugins fra wo-content/plguins/ med undtagelse af theme fusion plugins og derefter forsøge igen.

Skriv en kommentar