Vær forberedt: Opdatering kan give problemer med din hjemmeside

Mandag den 9. maj opdaterer UnoEuro softwaren på deres servere fra PHP 5 til PHP 7. For at du undgår færrest mulige problemer i forbindelse med opdateringen, er det uhyre vigtigt, at du får gearet din side til det nye system.

Vi vil derfor anbefale dig, at du bruger nogle minutter på at nærlæse følgende information. Her forklarer vi, hvilke udfordringer der kan opstå i forbindelse med opdateringen og giver dig nogle fif til, hvad du selv kan gøre for helt at undgå eller minimere problemerne.

Nyt system et markant løft

Det er lige nu højsæson for, at de førende webhost-udbydere skifter det gamle system PHP 5 – oftest version 5.3 eller 5.6 – ud med det nyeste PHP 7. Opdateringerne sker ikke uden grund, for med den nye software vil du fremover opleve en lang række fordele. Det gælder eksempelvis ved, at du får en højere hastighed på din side, og at den vil være bedre gearet til at håndtere større trafikmængder med mange brugere på sitet på samme tid. Teknisk set er opdateringen intet mindre end en milepæl, og derfor vil det desværre heller ikke foregå uden problemer for alle.

Det kan du selv gøre

Ved skift fra PHP 5 eller ældre versioner til PHP 7 vil der være funktioner, som bliver sat ud af drift. Derfor er det vigtigt, at du tager dine forholdsregler for at minimere risikoen for funktionsfejl. Du kan opleve problemer med din side, hvis den ikke er blevet opdateret gennem længere tid eller på anden måde gjort klar til at fungere med den nye software. Her kan den værste konsekvens blive, at du står med en hjemmeside, der ikke længere virker.

Her kan du opleve problemer

Nogle af de større problemer kan forekomme, hvis du bruger et eller flere af følgende programmer / funktioner:

  • MySQL extension
  • ereg extension
  • Iconcube – her vil særligt brugere af WHMCS opleve store problemer
  • Magento 1.9 samt ældre versioner
  • Joomla 3.4 samt ældre versioner
  • Drupal 7.0 – det vil virke hos de fleste – dog er det vigtigt, at eventuelle udvidelser i programmet er fuldt opdateret
  • Concrete 5 – vil ikke virke korrekt for alle

Hvad med WordPress?

Programmet er lidt udenfor kategori, da det er et gigantisk system med utallige muligheder for udvidelser. Derfor er det ikke muligt på forhånd at sige med sikkerhed, hvorvidt det vil fungere efter opdateringen. Her er man nødt til at se nærmere på de enkelte installationer. Hvis du stiller dig selv nedenstående spørgsmål, er du forholdsvist godt dækket ind.

  • Har jeg den nyeste version af WordPress?
  • Er alle plugins opdateret til nyeste version?
  • Er der nogle plugins, som ikke er blevet opdateret i mere end et år? Hvis der er, så anbefales det at se på, om de virker med PHP 7
  • Er alle temaer opdateret til nyeste version? Hvis der ikke er sendt en opdatering ud det seneste år, så anbefaler vi, at du tjekker, om det virker med PHP 7

Virker din side ikke efter opdateringen?

Hvis du på trods af at have taget alle forholdsregler stadig oplever problemer eller er i tvivl om din side virker, kan du få lavet en gennemgang af dit site hos os til en fornuftig timepris. Et eftersyn tager i gennemsnit fra en til tre timer per side – alt efter antallet af plugins, webhost samt tema. Hvis du ønsker at få foretaget opdateringer af din side, kan vi i nogle tilfælde gøre dette i forbindelse med vores gennemgang. Fejl, der ikke kan løses ved gennemgangen, vil vi levere en oversigt over, så du kan få problemerne udryddet i en fart.